Nation Safe Drivers- Quoting Down
Incident
06/02/2025, 3:50pm EDT
Nation Safe Drivers- Quoting Down
Status: closed
Start:
06/02/2025, 2:14pm EDT
End:
06/02/2025, 3:50pm EDT
Duration: 1 hour 36 minutes
Affected Components:
iQQ
iQQ - VPP - Nation Safe Driver (NSD)
Update
06/02/2025, 2:14pm EDT
06/02/2025, 2:14pm EDT
Vehicle Protection Plan (VPP) quoting through Nation Safe Drivers (NSD) is currently unavailable in IQQ.
Nation Safe Drivers is still researching and actively working on resolving the issue.
Please note this is only affecting NSD VPP clients, and no other products or providers in iQQ.
Thank you
Resolved
06/02/2025, 3:50pm EDT
06/02/2025, 3:50pm EDT
Quoting for Nation Safe Drivers is now resolved.
Thank you