Protective Outage

Incident
03/16/2026, 12:59pm EDT

Protective Outage

Status: closed
Start: 03/16/2026, 11:03am EDT
End: 03/16/2026, 12:59pm EDT
Duration: 1 hour 56 minutes
Affected Components:
iQQ iQQ - MBP - Protective
Update

03/16/2026, 11:03am EDT

03/16/2026, 11:03am EDT

Users selling MBP with Protective may be unable to get quotes and issue sales at this time.

We are corresponding with Protective for investigation and will send updates as they are available.

Resolved

03/16/2026, 12:59pm EDT

03/16/2026, 12:59pm EDT

Protective has confirmed the outage has been resolved and normal processing for Protective can now continue.