iQQ Server Performance - website slowness and timeouts

Incident
04/24/2026, 2:19pm EDT

iQQ Server Performance - website slowness and timeouts

Status: closed
Start: 04/22/2026, 4:06pm EDT
End: 04/24/2026, 2:19pm EDT
Duration: 1 day 22 hours 13 minutes
Affected Components:
iQQ iQQ - Quote & Sell iQQ - Printing iQQ - Remittance & Reports iQQ - Tools iQQ - MBP - Protective iQQ - MBP - APCO iQQ - MBP - Route 66 Extended Warranty iQQ - GAP / DPW iQQ - VPP - APCO iQQ - VPP - Nation Safe Driver (NSD) iQQ - ADR iQQ - Credit Protection
Update

04/22/2026, 4:06pm EDT

04/22/2026, 4:06pm EDT

Allied Solution's Infrastructure and iQQ Support teams are aware of an ongoing degradation of system performance within the iQQ application.   This has been tracked as a performance concern within the AWS cloud services.  Allied Infrastructure engineers are coordinating with AWS Engineers to address the performance.  No ETA is currently available for this issue.  We appreciate your patience as we work to restore optimal service.


-iQQ Support Team

Update

04/22/2026, 8:02pm EDT

04/22/2026, 8:02pm EDT

We are continuing to investigate the inconsistent system performance.  Observation and usage of the site shows the system generally performs as expected and then experiences a wave of slowdown and database errors, before returning to regular performance.

No cause has been identified at this time as we continue to analyze the servers for source of impact.

Resolved

04/24/2026, 2:19pm EDT

04/24/2026, 2:19pm EDT

The ongoing system performance issue has been resolved. Thank you for your patience during this time.

-iQQ Support Team